System Requirements

  • Minimum System Requirements needed for various programs:

    Starfall.com:
    Windows 95, Macintosh OS8, or Linux
    Internet connection
    64 MB Ram
    200 MHz processor
    Internet Explorer 4 or Netscape 4
    Flash Player 4

    Google Docs:
    Taken from: http://docs.google.com/support/bin/answer.py?answer=37560
    Google Docs supports the two latest versions of the following browsers:Google Chrome
    • Firefox
    • Safari
    • Internet Explorer*
    Note: Other browsers might work with Google Docs. However, we can't guarantee that features will work as expected.
    No matter what browser you use, you should enable cookies and JavaScript.

    *If you're working in Internet Explorer 8 and would like to edit Google drawings or create a Google presentation using the latest version, you need to install Google Chrome Frame or use another supported browser. If you use Google Apps, you may be unable to upgrade your browser on your own. In this case, please contact your administrator or your IT support for further assistance.

    The Khan Academy
    (Same requirements as Google Docs) This program works on the iPad2 and it may work on other devices that are relatively new to market.

    Rosetta Stone Foreign Language Software
    (Optional Fee-Based Extra Curricular Opportunity)

     Category  Recommended
     Web Browser Chrome 8 or higher
    Firefox 3 or higher
    Internet Explorer 6 or higher
    Safari 3 or higher
     Cookies  Enabled
     Adobe Flash Player  Version 9.0.47 or higher
     Speech Component  3.2.18 (Download from Rosetta Stone)
     Bandwidth  Broadband
     
Last Modified on June 1, 2014